* Sergei Shtylyov <sergei.shtyl...@cogentembedded.com> [191023 18:56]:
> On 10/23/2019 06:31 PM, Tony Lindgren wrote:
> > --- a/drivers/dma/ti/cppi41.c
> > +++ b/drivers/dma/ti/cppi41.c
> > @@ -586,9 +586,22 @@ static struct dma_async_tx_descriptor 
> > *cppi41_dma_prep_slave_sg(
> >     enum dma_transfer_direction dir, unsigned long tx_flags, void *context)
> >  {
> >     struct cppi41_channel *c = to_cpp41_chan(chan);
> > +   struct dma_async_tx_descriptor *txd = NULL;
> > +   struct cppi41_dd *cdd = c->cdd;
> >     struct cppi41_desc *d;
> >     struct scatterlist *sg;
> >     unsigned int i;
> > +   int error;
> > +
> > +   error = pm_runtime_get(cdd->ddev.dev);
> > +   if (error < 0) {
> 
>    I'd call that variable 'status', comparison (error < 0) just doesn't look 
> right.
> If it was *if* (error), it would have been more correct. 

Good suggestion, something to remember for next time.
In general error is widely used this way though:

$ git grep -A1 "error = " | grep "error < 0" | wc -l
425

Regards,

Tony

Reply via email to