Hi Geert and Shimoda-san,

On Fri, May 10, 2019, Geert Uytterhoeven wrote:
> > I think we can reuse it like below:
> >
> > - clock-names: Name of the clocks. This property is model-dependent.
> >   - R-Car Gen3 SoCs use a single functional clock. The clock doesn't
> need to be
> >     named.
> >   - RZ/A2 uses a single functional clock as a separate dedicated 48MHz
> 
> and a separate?
> 
> >     USB_X1 input. So, the functional clock must be named "???" and
> >     the USB_X1 input must be named as "usb_x1".
> >
> > What do you think? I'm not sure how to be named the functional clock so
> that
> > the sample is named as "???".
> 
> We typically use "fclk" for the functional clock's name.


Just to make sure I'm following this, here is what you are asking for:

[r7s9210.dtsi]

        usb2_phy1: usb-phy@e821a200 {
                compatible = "renesas,usb2-phy-r7s9210", 
"renesas,rcar-gen3-usb2-phy";
                reg = <0xe821a200 0x10>;
                interrupts = <GIC_SPI 36 IRQ_TYPE_LEVEL_HIGH>;
+               clocks = <&cpg CPG_MOD 60>, <&usb_x1_clk>;
+               clock-names = "fclk", "usb_x1";
                power-domains = <&cpg>;
                #phy-cells = <0>;
                status = "disabled";


[phy-rcar-gen3-usb2.c]
        usb_x1_clk = devm_clk_get(dev, "usb_x1");
        if (!IS_ERR(usb_x1_clk))
                if (clk_get_rate(usb_x1_clk))
                        channel->uses_usb_x1 = true;


And then document this in the bindings, saying that clock-names is 
option if there is only 1 clock (to be backward compatible with existing 
Device Trees.

Is this correct?

Thanks,
Chris

Reply via email to