On Fri, 30 Nov 2012, Sebastian Andrzej Siewior wrote:

> /sys/kernel/config/usb_gadget/gadgets/# mkdir oha
> /sys/kernel/config/usb_gadget/gadgets/oha# find
> .
> ./iSerialNumber
> ./iProduct
> ./iManufacturer
> ./bcdUSB
> ./idProduct
> ./idVendor
> ./bMaxPacketSize0
> ./bDeviceProtocol
> ./bDeviceSubClass
> ./bDeviceClass
> /sys/kernel/config/usb_gadget/gadgets/oha# echo blah > iProduct
> /sys/kernel/config/usb_gadget/gadgets/oha# cat iProduct
> blah

By the way, can you name these string attributes

        sSerialNumber, sProduct, and sManufacturer (etc.)

instead of

        iSerialNumber, iProduct, and iManufacturer (etc.)?

Or is it too late to change?

The iProduct,... names are already defined in the USB spec, and their 
meanings are different from the way you are using them here.  Since 
this will be a user-visible API, we should strive to be compatible with 
the spec.

Alan Stern

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to