On Tue, 3 Sep 2024, Jiaxun Yang wrote:

> Rename it as mips_insn, which is not conflicting with anything
> and fits the name of header.
[...]
> diff --git a/arch/mips/kernel/ftrace.c b/arch/mips/kernel/ftrace.c
> index 8c401e42301c..153c9666a77c 100644
> --- a/arch/mips/kernel/ftrace.c
> +++ b/arch/mips/kernel/ftrace.c
> @@ -248,7 +248,7 @@ int ftrace_disable_ftrace_graph_caller(void)
>  #define S_R_SP       (0xafb0 << 16)  /* s{d,w} R, offset(sp) */
>  #define OFFSET_MASK  0xffff  /* stack offset range: 0 ~ PT_SIZE */
>  
> -unsigned long ftrace_get_parent_ra_addr(unsigned long self_ra, unsigned long
> +static long ftrace_get_parent_ra_addr(unsigned long self_ra, unsigned long
>               old_parent_ra, unsigned long parent_ra_addr, unsigned long fp)
>  {
>       unsigned long sp, ip, tmp;

 This goes beyond renaming `mips_instruction' data type to `mips_insn'.

> diff --git a/arch/mips/kernel/kprobes.c b/arch/mips/kernel/kprobes.c
> index dc39f5b3fb83..7a1b1c3674da 100644
> --- a/arch/mips/kernel/kprobes.c
> +++ b/arch/mips/kernel/kprobes.c
> @@ -90,7 +90,7 @@ int arch_prepare_kprobe(struct kprobe *p)
>       }
>  
>       if (copy_from_kernel_nofault(&prev_insn, p->addr - 1,
> -                     sizeof(mips_instruction)) == 0 &&
> +                     sizeof(kprobe_opcode_t)) == 0 &&
>           insn_has_delayslot(prev_insn)) {
>               pr_notice("Kprobes for branch delayslot are not supported\n");
>               ret = -EINVAL;

 Likewise.

  Maciej

Reply via email to