Thank you for your contribution! Sashiko AI review found 1 potential issue(s) 
to consider:
- [Low] Tracepoint names violate the `subsystem_event` naming convention.
--

commit 247e0c64dd13ba460fb185bdf6a4727ca8e574bd
Author: Praveen Talari <[email protected]>

dmaengine: qcom: gpi: trace: Add trace events header for Qualcomm GPI DMA

This commit adds a tracepoint header for the Qualcomm GPI DMA engine driver.
The events provide runtime visibility into the driver's behavior, replacing
former debug logging.

> diff --git a/include/trace/events/qcom_gpi.h b/include/trace/events/qcom_gpi.h
> new file mode 100644
> index 0000000000000..5474e762f4b64
> --- /dev/null
> +++ b/include/trace/events/qcom_gpi.h
> @@ -0,0 +1,313 @@
> +/* SPDX-License-Identifier: GPL-2.0 */
> +#undef TRACE_SYSTEM
> +#define TRACE_SYSTEM qcom_gpi
> +
> +#if !defined(_TRACE_QCOM_GPI_H) || defined(TRACE_HEADER_MULTI_READ)
> +#define _TRACE_QCOM_GPI_H
> +
> +#include <linux/tracepoint.h>
> +
> +TRACE_EVENT(gpi_send_cmd,

[Severity: Low]
Should this tracepoint name be prefixed with the subsystem name to match the
subsystem_event naming convention?

Since TRACE_SYSTEM is defined as qcom_gpi above, defining the event as
gpi_send_cmd instead of qcom_gpi_send_cmd creates namespace inconsistencies in
tracing tools and debugfs. This naming pattern appears to be repeated for the
other TRACE_EVENT definitions in this file.

[ ... ]

-- 
Sashiko AI review ยท 
https://sashiko.dev/#/patchset/20260831-add-trace-support-gpio-v1-0-7b0fd0d0d...@oss.qualcomm.com?part=1

Reply via email to