On Mon Aug 10, 2026 at 8:51 AM BST, FUJITA Tomonori wrote: > From: FUJITA Tomonori <[email protected]> > > Macros whose expansion depends on the kernel configuration end up > ignoring some of their arguments, resulting in unused warnings. > > Add a macro for the `if false { _ = ...; }` idiom used to avoid them, > and convert the existing open-coded users in `warn_flags!` and > `declare_trace!`. > > Signed-off-by: FUJITA Tomonori <[email protected]>
Reviewed-by: Gary Guo <[email protected]> > --- > rust/kernel/bug.rs | 18 ++++-------------- > rust/kernel/lib.rs | 12 ++++++++++++ > rust/kernel/tracepoint.rs | 5 ++--- > 3 files changed, 18 insertions(+), 17 deletions(-) > > diff --git a/rust/kernel/bug.rs b/rust/kernel/bug.rs > index 3566f0234ca4..c1e4eb7d4a70 100644 > --- a/rust/kernel/bug.rs > +++ b/rust/kernel/bug.rs > @@ -55,9 +55,7 @@ macro_rules! warn_flags { > ($file:expr, $flags:expr) => { > const FLAGS: u32 = $crate::bindings::BUGFLAG_WARNING | $flags; > > - if false { > - _ = $file; > - } > + $crate::mark_used!($file); > > // SAFETY: > // - `flags` and `size` are all compile-time constants, preventing > @@ -83,9 +81,7 @@ macro_rules! warn_flags { > #[cfg(all(CONFIG_BUG, CONFIG_UML))] > macro_rules! warn_flags { > ($file:expr, $flags:expr) => { > - if false { > - _ = $file; > - } > + $crate::mark_used!($file); > > // SAFETY: It is always safe to call `warn_slowpath_fmt()` > // with a valid null-terminated string. > @@ -106,10 +102,7 @@ macro_rules! warn_flags { > #[cfg(all(CONFIG_BUG, any(CONFIG_LOONGARCH, CONFIG_ARM)))] > macro_rules! warn_flags { > ($file:expr, $flags:expr) => { > - if false { > - _ = $file; > - _ = $flags; > - } > + $crate::mark_used!($file, $flags); > > // SAFETY: It is always safe to call `WARN_ON()`. > unsafe { $crate::bindings::WARN_ON(true) } > @@ -121,10 +114,7 @@ macro_rules! warn_flags { > #[cfg(any(testlib, not(CONFIG_BUG)))] > macro_rules! warn_flags { > ($file:expr, $flags:expr) => { > - if false { > - _ = $file; > - _ = $flags; > - } > + $crate::mark_used!($file, $flags); > }; > } > > diff --git a/rust/kernel/lib.rs b/rust/kernel/lib.rs > index 9512af7156df..2f770d80bd8a 100644 > --- a/rust/kernel/lib.rs > +++ b/rust/kernel/lib.rs > @@ -266,6 +266,18 @@ macro_rules! container_of { > #[doc(hidden)] > pub fn assert_same_type<T>(_: T, _: T) {} > > +/// Marks the given expressions as used. > +/// > +/// This avoids "unused" warnings in kernel configurations that do not > otherwise use them. > +#[macro_export] > +macro_rules! mark_used { > + ($($e:expr),* $(,)?) => { > + if false { > + $( _ = $e; )* > + } > + }; > +} > + > /// Helper for `.rs.S` files. > #[doc(hidden)] > #[macro_export] > diff --git a/rust/kernel/tracepoint.rs b/rust/kernel/tracepoint.rs > index c6e80aa99e8e..cb06fec4c4d9 100644 > --- a/rust/kernel/tracepoint.rs > +++ b/rust/kernel/tracepoint.rs > @@ -38,9 +38,8 @@ macro_rules! declare_trace { > > #[cfg(not(CONFIG_TRACEPOINTS))] > { > - // If tracepoints are disabled, insert a trivial use of each > argument > - // to avoid unused argument warnings. > - $( let _unused = $argname; )* > + // If tracepoints are disabled, the arguments are unused. nit: the comment seems redundant now that the macro name is self-documenting. Best, Gary > + $crate::mark_used!($($argname),*); > } > } > )*} > > base-commit: d8973c47544371613313ecb9a8c3e7b244aa9bbf
