> If I understand the patch above, you basically have:
>
>       if (....)
>               goto out;
>       else
>               ret = ufshcd_resume();
> out:
>
> Wouldn't it be better to just reverse the above if condition?
>
>       if (!...)
>               ret = ufshcd_resume();
>
> That would be much less confusing.

It gives a logical place to put the comment, but I agree it will be
less confusing the other way.
I will fix this in the next patchset.

-- 
Qualcomm Israel, on behalf of Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
a Linux Foundation Collaborative Project

--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to