On Mon, 22 Oct 2007, Matthew Wilcox wrote:
>
> Introduce new __holds() macro to tell sparse it's OK to drop and then
> reacquire a lock within a function.  Use it in scsi_request_fn.

Umm. This is why we write things like

        static void double_lock_balance(struct rq *this_rq, struct rq *busiest)
                __releases(this_rq->lock)
                __acquires(busiest->lock)
                __acquires(this_rq->lock)
        {
                ...

ie your "__holds()" is nothing new, and should be written as 
a pair of __releases(x) and __acquires(x), which is more readable anyway 
(since it actually says what the function does!)

                Linus
-
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to