Hi Hans,

On Thu, Sep 26, 2019 at 08:58:27AM +0200, Hans Verkuil wrote:
> We currently have the following devnode types:
> 
> enum vfl_devnode_type {
>         VFL_TYPE_GRABBER        = 0,
>         VFL_TYPE_VBI,
>         VFL_TYPE_RADIO,
>         VFL_TYPE_SUBDEV,
>         VFL_TYPE_SDR,
>         VFL_TYPE_TOUCH,
>         VFL_TYPE_MAX /* Shall be the last one */
> };
> 
> They all make sense, except for the first: GRABBER really refers to 
> /dev/videoX
> devices, which can be capture, output or m2m, so 'grabber' doesn't even refer 
> to
> their function anymore.
> 
> Let's call a spade a spade and rename this to VFL_TYPE_VIDEO.
> 
> Signed-off-by: Hans Verkuil <hverkuil-ci...@xs4all.nl>
> ---
> This patch converts the core files. If others are OK with this, then I can 
> post
> a full series that also converts all drivers that use it (very easy 
> search-and-replace)
> and finally remove the old GRABBER enum.

Acked-by: Sakari Ailus <sakari.ai...@linux.intel.com>

-- 
Sakari Ailus

Reply via email to