Hi Ilpo,

Function name in shortlog does not match the patch.

On 5/20/24 5:30 AM, Ilpo Järvinen wrote:
measure_val() is awfully generic name so rename it to measure_mem_bw()

measure_val() -> measure_vals()

to describe better what it does and document the function parameters.

Signed-off-by: Ilpo Järvinen <ilpo.jarvi...@linux.intel.com>
---
  tools/testing/selftests/resctrl/resctrl_val.c | 12 +++++++++---
  1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/tools/testing/selftests/resctrl/resctrl_val.c 
b/tools/testing/selftests/resctrl/resctrl_val.c
index 198b5133432a..6c53eb9171ea 100644
--- a/tools/testing/selftests/resctrl/resctrl_val.c
+++ b/tools/testing/selftests/resctrl/resctrl_val.c
@@ -637,8 +637,14 @@ static void initialize_llc_occu_resctrl(const char 
*ctrlgrp, const char *mongrp,
                set_cmt_path(ctrlgrp, mongrp, domain_id);
  }
-static int measure_vals(const struct user_params *uparams,
-                       struct resctrl_val_param *param, pid_t bm_pid)
+/*
+ * measure_mem_bw - Measures memory bandwidth numbers while benchmark runs
+ * @uparams:           User supplied parameters
+ * @param:             parameters passed to resctrl_val()

Please consistently start descriptions with upper case.

+ * @bm_pid:            PID that runs the benchmark
+ */
+static int measure_mem_bw(const struct user_params *uparams,
+                         struct resctrl_val_param *param, pid_t bm_pid)
  {
        unsigned long bw_resc, bw_resc_start, bw_resc_end;
        FILE *mem_bw_fp, *mem_bw_fp2;
@@ -912,7 +918,7 @@ int resctrl_val(const struct resctrl_test *test,
if (!strncmp(resctrl_val, MBM_STR, sizeof(MBM_STR)) ||
                    !strncmp(resctrl_val, MBA_STR, sizeof(MBA_STR))) {
-                       ret = measure_vals(uparams, param, bm_pid);
+                       ret = measure_mem_bw(uparams, param, bm_pid);
                        if (ret)
                                break;
                } else if (!strncmp(resctrl_val, CMT_STR, sizeof(CMT_STR))) {

With typos fixed:

| Reviewed-by: Reinette Chatre <reinette.cha...@intel.com>

Reinette


Reply via email to