* Aravind Gopalakrishnan <aravind.gopalakrish...@amd.com> wrote: > This function doesn't give us the "Node ID" as the function > name suggests. Rather- it receives a PCI device as argument, > checks the available F3 PCI device IDs in the system > and returns the index of the matching Bus/Device IDs > > Renaming it accordingly in this patch. > No functional change is introduced. > > Signed-off-by: Aravind Gopalakrishnan <aravind.gopalakrish...@amd.com> > --- > arch/x86/include/asm/amd_nb.h | 2 +- > drivers/edac/amd64_edac.c | 6 +++--- > 2 files changed, 4 insertions(+), 4 deletions(-) > > diff --git a/arch/x86/include/asm/amd_nb.h b/arch/x86/include/asm/amd_nb.h > index 1a5da2e..319843d 100644 > --- a/arch/x86/include/asm/amd_nb.h > +++ b/arch/x86/include/asm/amd_nb.h > @@ -81,7 +81,7 @@ static inline struct amd_northbridge *node_to_amd_nb(int > node) > return (node < amd_northbridges.num) ? &amd_northbridges.nb[node] : > NULL; > } > > -static inline u16 amd_get_node_id(struct pci_dev *pdev) > +static inline u16 amd_get_node_id_from_pci_dev(struct pci_dev *pdev)
So if we go to the trouble of naming things properly, I guess that function should be named: amd_pci_dev_to_node_id() or so. Thanks, Ingo -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/