Hello.

On 10/14/2015 4:07 AM, Daniel Kurtz wrote:

Add Mediatek nor flash node

Signed-off-by: Bayi Cheng <bayi.ch...@mediatek.com>
---
   arch/arm64/boot/dts/mediatek/mt8173.dtsi | 15 +++++++++++++++
   1 file changed, 15 insertions(+)

diff --git a/arch/arm64/boot/dts/mediatek/mt8173.dtsi
b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
index d18ee42..385c2e4 100644
--- a/arch/arm64/boot/dts/mediatek/mt8173.dtsi
+++ b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
@@ -365,6 +365,21 @@
                         status = "disabled";
                 };

+               nor_flash: spi@1100d000 {

    I don't think this is a good label name for a SPI controller.

You think "spi" is not a good name for SPI controller?
Or you mean the label "nor_flash"?

   I think I said clearly: "label". :-)

Would you prefer:

   spi_nor_flash: spi@1100d000

I'd prefer the "_nor_flash" part to be dropped, to be used for the real flash device (if needed) which is a sub-node of this node.

[...]

-Dan

MBR, Sergei

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to