On Tue, Oct 06, 2015 at 09:20:53AM +0200, Olliver Schinagl wrote: > Hey Thierry, list, > > While working on something in the pwm framework, I noticed that the void > *data in the pwm_device struct is called chip_data. Why is it not called > device_data, since it is the data associated with a PWM device, rather then > the chip, and on that note, if it really is chip related data (thus covering > the whole chip, not just the single pwm device) why is there no chip_data in > pwm_chip?
The reason for the name is that it's chip-specific data associated with a struct pwm_device. That is, a PWM chip implementation (i.e. driver) can use it to keep per-PWM data that's not in struct pwm_device itself. > Again, is this something worth my time to add a device_data and rename > chip_data? device_data would be redundant because it's already part of struct pwm_device. Plain data might be okay, but I like the chip_ prefix because it marks the data as being chip-specific data rather than generic. Thierry
signature.asc
Description: PGP signature