Hello.

On 10/5/2015 6:16 AM, Greg KH wrote:

Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

Why?

   Seemed a good idea to me back in March. :-)

I hate PCI_VDEVICE(), it's impossible to grep for things and does

   Didn't think about grepping...

not help with readability and is pointless.  My one wish was that when I
was the PCI maintainer I would have just deleted the thing from the
kernel entirely instead of leaving it there hoping no one would use it.

   Thanks for the idea. :-)

I don't like these types of pointless patches, sorry.

   I hope you don't have the same strong feelings about PCI_DEVICE_SUB().
There's one place (in ohci-pci.c IIRC) it can be used...

thanks,

greg k-h

MBR, Sergei

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to