On Fri, Jun 12, 2015 at 2:45 AM, Thierry Reding <thierry.red...@gmail.com> wrote: > On Tue, May 26, 2015 at 01:08:16PM -0700, Jonathan Richardson wrote: >> From: Tim Kryger <tim.kry...@gmail.com> >> >> Add a new function to register a PWM chip with channels that have their >> initial polarity as inversed. This benefits drivers of controllers that >> by default operate with inversed polarity by removing the need to modify >> the polarity during initialization. >> >> Signed-off-by: Tim Kryger <tim.kry...@gmail.com> >> Signed-off-by: Jonathan Richardson <jonat...@broadcom.com> >> --- >> drivers/pwm/core.c | 36 ++++++++++++++++++++++++++++-------- >> include/linux/pwm.h | 6 ++++++ >> 2 files changed, 34 insertions(+), 8 deletions(-) > > I had to bikeshed this a little, so I ended up applying a variant that > exports pwmchip_add_with_polarity() instead of having the additional > wrapper. The rationale here is that pwmchip_add_with_polarity() is more > explicit than pwmchip_add_inversed(). > > Thierry
Sounds good. Thanks. -Tim -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/