Hi Joe and Alexandre,

On Tue, 2015-05-05 at 23:01 +0200, Alexandre Belloni wrote:
> On 05/05/2015 at 13:44:21 -0700, Joe Perches wrote :
> > I suggest moving the time_after() test into the loop,
> > use break; and remove the exit label too.
> > 
> > Maybe something like:
> > 
> >     while (1) {
> >             ret = regmap_read(rtc->regmap, rtc->addr_base + RTC_BBPU,
> >                               &data);
> >             if (ret < 0)
> >                     break;
> >             if (!(data & RTC_BBPU_CBUSY))
> >                     break;
> >             if (time_after(jiffies, timeout)) {
> >                     ret = -ETIMEDOUT;
> >                     break;
> >             }
> >             cpu_relax();
> >     }
> > 
> >     return ret;
> 
> That certainly looks more readable.
> 

Thanks correct me that I put wrong paramters in time_after, and give me
good example. I will adopt your suggestion in next round.

Eddie


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to