On Wed, Apr 22, 2015 at 12:42 AM, Johan Hovold <jo...@kernel.org> wrote: > Rename the gpio-chip export/unexport functions to the more descriptive > names gpiochip_register and gpiochip_unregister.
Since these functions are related to sysfs, wouldn't gpiochip_sysfs_export (or gpiochip_sysfs_register, although the former sounds better to me) be even more descriptive? The renaming should probably also cover the non-static gpiod_* functions of gpiolib-sysfs.c which are equally ambiguous. Basically anything non-static from gpiolib-sysfs.c should have that prefix. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/