> > > > > validate_group(struct perf_event *event) > > > > > { > > > > > struct perf_event *sibling, *leader = event->group_leader; > > > > > - struct cci_pmu_hw_events fake_pmu = { > > > > > - /* > > > > > - * Initialise the fake PMU. We only need to populate the > > > > > - * used_mask for the purposes of validation. > > > > > - */ > > > > > - .used_mask = CPU_BITS_NONE, > > > > > > > > Can we not simply change this to: > > > > > > > > .used_mask = { 0 }, > > > > > > > > That should result in the entire array being zeroed. > > > > > > It does, but it also causes the whole struct to be cleared. > > > > Sure, but it's also the minimal diff, and it's easier to read. This was > > what the code was intended to be initially. > > > > > With the memset, only used_mask gets cleared. > > > > Is there an appreciable difference between the two performance-wise? > > I dunno. It is 3 strp insns vs 1 str. > If you want the static init, I'll send another patch.
I'd prefer the designated initializer to the memset. Thanks, Mark. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/