On Sun, Feb 01, 2015 at 11:55:37AM -0500, Nicholas Mc Guire wrote: > return type of wait_for_completion_timeout is unsigned long not int, this > patch uses the return value of wait_for_completion_timeout in the condition > directly rather than assigning it to an incorrect type variable. > > The timeout declaration cleanup is just for readability > > Signed-off-by: Nicholas Mc Guire <hof...@osadl.org> > --- > > The variable used for handling the return of wait_for_cmpletion_timeout > was int but should be unsigned long, where it was not in use for anything > else and the return value in case of completion (>0) is not used it was > removed and wait_for_completion_timeout() used directly in the if condition. > > To make the timeout values a bit simpler to read and also handle all of > the corner cases correctly the declarations are moved to msecs_to_jiffies(). > > This patch was only compile tested for pxa3xx_defconfig > (implies CONFIG_MTD_NAND_PXA3xx=y) > > Patch is against 3.0.19-rc6 -next-20150130
Reworked the commit message a bit and pushed to l2-mtd.git. Brian -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/