On Saturday 21 March 2015, Richard Cochran wrote:
> -static int bfin_ptp_gettime(struct ptp_clock_info *ptp, struct timespec *ts)
> +static int bfin_ptp_gettime(struct ptp_clock_info *ptp, struct timespec64 
> *ts)
>  {
>         u64 ns;
>         u32 remainder;

I think it would be good to replace the open-coded 

        ns = ts->tv_sec * 1000000000ULL;
        ns += ts->tv_nsec;

here with a call to ns_to_timespec64(), here and in other drivers that you
are already touching.

        Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to