Rename these two functions that have really disturbing names for this irqdomain namespace.
Having them prefixed just irq_* and deviating from the irq_domain* prefix convention for the domain just sets off my OCD. Linus Walleij (2): kernel: irq: rename irq_find_host() to irq_domain_lookup() kernel: irq: rename irq_set_default_host to irq_domain_set_default() arch/arc/kernel/irq.c | 2 +- arch/arm/mach-pxa/irq.c | 2 +- arch/c6x/kernel/irq.c | 2 +- arch/microblaze/kernel/intc.c | 2 +- arch/mips/cavium-octeon/octeon-irq.c | 4 ++-- arch/nios2/kernel/irq.c | 2 +- arch/powerpc/platforms/52xx/mpc52xx_pic.c | 2 +- arch/powerpc/platforms/amigaone/setup.c | 2 +- arch/powerpc/platforms/cell/axon_msi.c | 2 +- arch/powerpc/platforms/cell/beat_interrupt.c | 2 +- arch/powerpc/platforms/cell/interrupt.c | 2 +- arch/powerpc/platforms/chrp/setup.c | 2 +- arch/powerpc/platforms/embedded6xx/flipper-pic.c | 2 +- arch/powerpc/platforms/powermac/pic.c | 2 +- arch/powerpc/platforms/ps3/interrupt.c | 2 +- arch/powerpc/sysdev/ehv_pic.c | 2 +- arch/powerpc/sysdev/ipic.c | 2 +- arch/powerpc/sysdev/mpic.c | 2 +- arch/powerpc/sysdev/uic.c | 2 +- arch/powerpc/sysdev/xics/xics-common.c | 2 +- arch/powerpc/sysdev/xilinx_intc.c | 2 +- arch/x86/kernel/apic/io_apic.c | 2 +- drivers/irqchip/irq-armada-370-xp.c | 2 +- drivers/irqchip/irq-clps711x.c | 2 +- drivers/irqchip/irq-mmp.c | 8 ++++---- drivers/irqchip/irq-mtk-sysirq.c | 2 +- drivers/irqchip/irq-xtensa-mx.c | 4 ++-- drivers/irqchip/irq-xtensa-pic.c | 4 ++-- drivers/of/irq.c | 2 +- include/linux/irqdomain.h | 20 ++++++++++---------- kernel/irq/irqdomain.c | 18 +++++++++--------- 31 files changed, 54 insertions(+), 54 deletions(-) -- 1.9.3 -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/