On Wed, Jan 28, 2015 at 11:26:09AM +0000, Javi Merino wrote:
> On Wed, Jan 28, 2015 at 03:35:57AM +0000, Steven Rostedt wrote:
> > On Mon, 26 Jan 2015 12:11:49 +0000
> > Javi Merino <javi.mer...@arm.com> wrote:
> > 
> > > From: Dave Martin <dave.mar...@arm.com>
> > > 
> > > If a trace event contains an array, there is currently no standard
> > > way to format this for text output.  Drivers are currently hacking
> > > around this by a) local hacks that use the trace_seq functionailty
> > > directly, or b) just not printing that information.  For fixed size
> > > arrays, formatting of the elements can be open-coded, but this gets
> > > cumbersome for arrays of non-trivial size.
> > > 
> > > These approaches result in non-standard content of the event format
> > > description delivered to userspace, so userland tools needs to be
> > > taught to understand and parse each array printing method
> > > individually.
> > > 
> > > This patch implements common __print_<type>_array() helpers that
> > > tracepoint implementations can use instead of reinventing them.  A
> > > simple C-style syntax is used to delimit the array and its elements
> > > {like,this}.
> > > 
> > > So that the helpers can be used with large static arrays as well as
> > > dynamic arrays, they take a pointer and element count: they can be
> > > used with __get_dynamic_array() for use with dynamic arrays.
> > > 
> > > Cc: Steven Rostedt <rost...@goodmis.org>
> > > Cc: Ingo Molnar <mi...@redhat.com>
> > > Signed-off-by: Dave Martin <dave.mar...@arm.com>
> > > Signed-off-by: Javi Merino <javi.mer...@arm.com>
> > > ---
> > >  include/linux/ftrace_event.h |  4 ++++
> > >  include/trace/ftrace.h       |  9 +++++++++
> > >  kernel/trace/trace_output.c  | 44 
> > > ++++++++++++++++++++++++++++++++++++++++++++
> > >  3 files changed, 57 insertions(+)
> > > 
> > > diff --git a/include/linux/ftrace_event.h b/include/linux/ftrace_event.h
> > > index 0bebb5c348b8..5aa4a9269547 100644
> > > --- a/include/linux/ftrace_event.h
> > > +++ b/include/linux/ftrace_event.h
> > > @@ -44,6 +44,10 @@ const char *ftrace_print_bitmask_seq(struct trace_seq 
> > > *p, void *bitmask_ptr,
> > >  const char *ftrace_print_hex_seq(struct trace_seq *p,
> > >                            const unsigned char *buf, int len);
> > >  
> > > +const char *ftrace_print_array_seq(struct trace_seq *p,
> > > +                            const void *buf, int buf_len,
> > > +                            size_t el_size);
> > > +
> > >  struct trace_iterator;
> > >  struct trace_event;
> > >  
> > > diff --git a/include/trace/ftrace.h b/include/trace/ftrace.h
> > > index 139b5067345b..36afd0ed3458 100644
> > > --- a/include/trace/ftrace.h
> > > +++ b/include/trace/ftrace.h
> > > @@ -263,6 +263,14 @@
> > >  #undef __print_hex
> > >  #define __print_hex(buf, buf_len) ftrace_print_hex_seq(p, buf, buf_len)
> > >  
> > > +#undef __print_array
> > > +#define __print_array(array, count, el_size)                             
> > > \
> > > + ({                                                              \
> > > +         BUILD_BUG_ON(el_size != 8 && el_size != 16 &&           \
> > > +                 el_size != 32 && el_size != 64);                \
> > 
> > I tried testing this patch by writing a print_array myself, and I kept
> > hitting this BUILD_BUG_ON, and was wondering WTF? Then it dawned on me.
> > 
> > el_size should not be based on bits, it should be based on bytes. I
> > passed in "sizeof()" which doesn't work with bits.

Ugh.  If you use sizeof() in print_array() then trace-cmd won't be
able to parse it since it doesn't have an implementation of sizeof().

  [thermal_power_allocator:thermal_power_allocator] function sizeof not defined
  Error: expected type 5 but read 0
*** Error in `./trace-cmd': double free or corruption (fasttop): 
0x0000000000e04980 ***

Implementing a fully functional sizeof() in trace-cmd will be a huge
beast, I guess you will have to limit it to only some types.

> > Please update to "el_size < 1 || el_size > 8".
> > 
> > and adjust the rest accordingly.
> 
> Done, I'm testing it now.  I'll send a v5 later today.
> 
> Cheers,
> Javi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to