On 2014년 12월 20일 09:24, Pavel Machek wrote:

> Subject: charging.
> 


(snip..)


>> --- a/include/linux/power/charger-manager.h
>> +++ b/include/linux/power/charger-manager.h
>> @@ -220,6 +220,7 @@ struct charger_desc {
>>   *  saved status of battery before entering suspend-to-RAM
>>   * @charging_start_time: saved start time of enabling charging
>>   * @charging_end_time: saved end time of disabling charging
>> + * @battery_status: Current battery status
> 
> "current" for consistency.
> 
>>   */
>>  struct charger_manager {
>>      struct list_head entry;
>> @@ -237,6 +238,8 @@ struct charger_manager {
>>  
>>      u64 charging_start_time;
>>      u64 charging_end_time;
>> +
>> +    int battery_status;
>>  };
> 
> Should battery_status be some kind of enum?


Currently, it stores only enum of power_supply class's and it doesn't have
specified type. And also, I didn't want to make additional private enums.
I'd let it to be as it was.

Thanks,
Jonghwa

>                                                                       Pavel
> --                                            
> (english) http://www.livejournal.com/~pavelmachek
> (cesky, pictures) 
> http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
> 


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to