On Mon, Dec 1, 2014 at 4:56 PM, Jilai Wang <jil...@codeaurora.org> wrote:
> +               /* Enable HDCP Encryption */
> +               hdmi_write(hdmi, REG_HDMI_HDCP_CTRL, BIT(0) | BIT(8));

btw, as Bjron mentioned, there are a lot of these open coded BIT(n)..
but from a quick check, the first two or three I looked at, we already
have the appropriate defines in the rnndb generated headers, to
instead do:

        /* Enable HDCP Encryption */
        hdmi_write(hdmi, REG_HDMI_HDCP_CTRL,
                HDMI_HDCP_CTRL_ENABLE |
                HDMI_HDCP_CTRL_ENCRYPTION_ENABLE);

that seems somewhat more readable to me ;-)

BR,
-R
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to