Hello, On Wed, Nov 26, 2014 at 09:35:10AM +0100, Lukasz Majewski wrote: > Hi Eduardo, > > > Hello Lukasz, > > > > On Thu, Nov 20, 2014 at 05:21:27PM +0100, Lukasz Majewski wrote: > > > This patch extends the of-thermal.c to export copy of trip points > > > for a given thermal zone. > > > > > > Thermal drivers should use of_thermal_get_trip_points() method to > > > get pointer to table of thermal trip points. > > > > > > Signed-off-by: Lukasz Majewski <l.majew...@samsung.com> > > > --- > > > Changes for v2: > > > - New patch - as suggested by Eduardo Valentin > > > --- > > > drivers/thermal/of-thermal.c | 33 > > > +++++++++++++++++++++++++++++++++ drivers/thermal/thermal_core.h | > > > 7 +++++++ include/linux/thermal.h | 14 ++++++++++++++ > > > 3 files changed, 54 insertions(+) > > > > > > diff --git a/drivers/thermal/of-thermal.c > > > b/drivers/thermal/of-thermal.c index 336af7f..33921c5 100644 > > > --- a/drivers/thermal/of-thermal.c > > > +++ b/drivers/thermal/of-thermal.c > > > @@ -89,6 +89,7 @@ struct __thermal_zone { > > > /* trip data */ > > > int ntrips; > > > struct __thermal_trip *trips; > > > + struct thermal_trip *gtrips; > > > > > > /* cooling binding data */ > > > int num_tbps; > > > @@ -152,6 +153,27 @@ bool of_thermal_is_trip_en(struct > > > thermal_zone_device *tz, int trip) return true; > > > } > > > > > > +/** > > > + * of_thermal_get_trip_points - function to get access to a > > > globally exported > > > + * trip points > > > + * > > > + * @tz: pointer to a thermal zone > > > + * > > > + * This function provides a pointer to the copy of trip points > > > table > > > + * > > > + * Return: pointer to trip points table, NULL otherwise > > > + */ > > > +const struct thermal_trip * const > > > +of_thermal_get_trip_points(struct thermal_zone_device *tz) > > > +{ > > > + struct __thermal_zone *data = tz->devdata; > > > + > > > + if (!data) > > > + return NULL; > > > + > > > + return data->gtrips; > > > +} > > > + > > > > EXPORT_SYMBOL_GPL(of_thermal_get_trip_points); > > Ok. > > > > > > static int of_thermal_get_trend(struct thermal_zone_device *tz, > > > int trip, enum thermal_trend *trend) > > > { > > > @@ -767,6 +789,16 @@ thermal_of_build_thermal_zone(struct > > > device_node *np) goto free_tbps; > > > } > > > > > > + tz->gtrips = kcalloc(tz->ntrips, sizeof(*tz->gtrips), > > > GFP_KERNEL); > > > + if (!tz->gtrips) { > > > + ret = -ENOMEM; > > > + goto free_tbps; > > > + } > > > + > > > + for (i = 0; i < tz->ntrips; i++) > > > + memcpy(&(tz->gtrips[i]), > > > &(tz->trips[i].temperature), > > > + sizeof(*tz->gtrips)); > > > + > > > finish: > > > of_node_put(child); > > > tz->mode = THERMAL_DEVICE_DISABLED; > > > @@ -793,6 +825,7 @@ static inline void of_thermal_free_zone(struct > > > __thermal_zone *tz) { > > > int i; > > > > > > + kfree(tz->gtrips); > > > for (i = 0; i < tz->num_tbps; i++) > > > of_node_put(tz->tbps[i].cooling_device); > > > kfree(tz->tbps); > > > diff --git a/drivers/thermal/thermal_core.h > > > b/drivers/thermal/thermal_core.h index 466208c..a9580ca 100644 > > > --- a/drivers/thermal/thermal_core.h > > > +++ b/drivers/thermal/thermal_core.h > > > @@ -91,6 +91,8 @@ int of_parse_thermal_zones(void); > > > void of_thermal_destroy_zones(void); > > > int of_thermal_get_ntrips(struct thermal_zone_device *); > > > bool of_thermal_is_trip_en(struct thermal_zone_device *, int); > > > +const struct thermal_trip * const > > > +of_thermal_get_trip_points(struct thermal_zone_device *); > > > #else > > > static inline int of_parse_thermal_zones(void) { return 0; } > > > static inline void of_thermal_destroy_zones(void) { } > > > @@ -102,6 +104,11 @@ static inline bool > > > of_thermal_is_trip_en(struct thermal_zone_device *, int) { > > > > This produces compilation error when CONFIG_THERMAL_OF is not set. > > Name the parameters to fix. > > As all the other cases, I will fix that. > > > > > > return 0; > > > } > > > +static inline const struct thermal_trip * const > > > +of_thermal_get_trip_points(struct thermal_zone_device *) > > > +{ > > > + return NULL; > > > +} > > > #endif > > > > > > #endif /* __THERMAL_CORE_H__ */ > > > diff --git a/include/linux/thermal.h b/include/linux/thermal.h > > > index 5bc28a7..88d7249 100644 > > > --- a/include/linux/thermal.h > > > +++ b/include/linux/thermal.h > > > @@ -303,6 +303,20 @@ struct thermal_zone_of_device_ops { > > > int (*get_trend)(void *, long *); > > > }; > > > > > > +/** > > > + * struct thermal_trip - Structure representing themal trip points > > > exported from > > > + * of-thermal > > > + * > > > > The only problem I have with this name is that would look like it is > > in use in all thermal framework, which is not really the case. But I > > do think having a type here is a good thing. So, not sure :-) > > It can stay to be struct thermal_trip or we can rename it to > struct of_thermal_trip. > > I'm fine with both names.
Leave it as 'thermal_trip'. > > > > > > + * @temperature: trip point temperature > > > + * @hysteresis: trip point hysteresis > > > + * @type: trip point type > > > + */ > > > +struct thermal_trip { > > > + unsigned long int temperature; > > > + unsigned long int hysteresis; > > > + enum thermal_trip_type type; > > > +}; > > > + > > > /* Function declarations */ > > > #ifdef CONFIG_THERMAL_OF > > > struct thermal_zone_device * > > > -- > > > 2.0.0.rc2 > > > > > > > -- > Best regards, > > Lukasz Majewski > > Samsung R&D Institute Poland (SRPOL) | Linux Platform Group
signature.asc
Description: Digital signature