On Monday 10 November 2014 10:05:26 Jean-Francois Moine wrote:
> On Mon, 10 Nov 2014 09:39:57 +0100
> Arnd Bergmann <a...@arndb.de> wrote:
> 
> > On Sunday 09 November 2014 12:22:21 Jean-Francois Moine wrote:
> > > -- sound-dai                            : phandle and port of CPU/CODEC
> > > +either
> > > +  - sound-dai                          : phandle and port of CPU/CODEC
> > > +or
> > > +  - sound-dais                         : list of phandle and port of 
> > > CODECs
> > 
> > Is it really necessary to change the property name here? I woudl think
> > that you can make it all work more consistently with just the existing
> > 'sound-dai' property, just extend it to allow multiple codecs
> 
> This was an idea from Benoit Cousson:
> 
>  "Something like that:
> 
>    sound-dais = <&spdif_codec 1>, <&hdmi 0>;
> 
>  That being said, it will require changing the name with a plural form,"
> 
> As I coded it, both names are accepted for a single or many codecs.

I don't see a strong reason for coming up with a plural form. If you really
have to, then please list the old form as a deprecated alias and make the
document talk about "sound-dais" as the preferred form independent of the
number of arguments.

        Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to