On Tue, 22 Mar 2005 03:51:04 +0100, Johannes Stezenbach <[EMAIL PROTECTED]> wrote: > On Mon, Mar 21, 2005 at 05:10:27PM +0100, Magnus Damm wrote: > > Remove "dvb_"-prefix from parameters. Without the patch all parameters > > except > > the declaration of parameter "frontend_debug" have a "dvb_"-prefix. > > Why is that dvb_ prefix a problem?
It is no biggie and probably not worth breaking users' configuration like you said, but most drivers do not have their KBUILD_MODNAME included in the parameter names. Setting parameters that have KBUILD_MODNAME as prefix from the kernel commandline is then done by KBUILD_MODNAME.KBUILD_MODNAME_xxx and that is plain ugly - especially when a list of parameters are generated from the source. Some bad citizens IMO: dvb.dvb_shutdown_timeout, asus.asus_gid, arlan.arlan_entry_debug > > Error detected with section2text.rb, see autoparam patch. > > Please only fix errors and do not rename other parameters. We shouldn't > break users' modprobe.conf option settings. Ok, just fixing errors: frontend_debug should be renamed to dvb_frontend_debug or the parameter description should at least match the parameter... Thanks, / magnus - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/