* Oleg Nesterov <[EMAIL PROTECTED]> wrote: > New rules: > ->_base & 1 : is timer pending > ->_base & ~1 : timer's base
how would it look like if we had a separate timer->pending field after all? Would it be faster/cleaner? (we dont need to keep them small _that_ bad - if there's a good reason we should rather add a clean new field than to encode two fields into one field and complicate the code.) Ingo - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/