On Wed, Jul 23, 2014 at 11:07:40AM -0700, Linus Torvalds wrote: > - *static* per-cpu allocations might want to use "cpumask_var_t" (to > avoid having a full "struct cpumask_t") along with doing a > "zalloc_cpumask_var_node(..)" for each cpu. > > sched_init() follows that last pattern, except it open-codes that > zalloc_cpumask_var_node() in an odd way that confused me. > > So I take my patch back. It's wrong, because it only allocates that > cpumask_size() if CONFIG_CPUMASK_OFFSTACK is true.
What it doesn't do is keep the allocation on the right node, so killing that stuff is helping more than just readability. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/