On Thu, Jul 10, 2014 at 08:56:00AM -0500, Felipe Balbi wrote:
> On Thu, Jul 10, 2014 at 03:51:24PM +0200, Antoine Ténart wrote:
> > On Thu, Jul 10, 2014 at 08:42:27AM -0500, Felipe Balbi wrote:
> > > On Wed, Jul 09, 2014 at 12:17:16PM +0200, Antoine Ténart wrote:
> > > > This patch adds the support to the PHY framework for ChipIdea drivers
> > > > while keeping the USB PHY compatibility. Changes are done in both the
> > > > ChipIdea common code and in the drivers accessing the PHY. This is done
> > > > by renaming 'phy' into 'usb_phy' and adding a new 'phy' member into the
> > > > ci_hdrc structre.
> > > > 
> > > > Signed-off-by: Antoine Ténart <antoine.ten...@free-electrons.com>
> > > > ---
> > > >  drivers/usb/chipidea/ci.h          |  4 ++-
> > > >  drivers/usb/chipidea/ci_hdrc_imx.c |  2 +-
> > > >  drivers/usb/chipidea/ci_hdrc_msm.c |  6 ++--
> > > >  drivers/usb/chipidea/core.c        | 67 
> > > > +++++++++++++++++++++++++++++++-------
> > > >  drivers/usb/chipidea/debug.c       |  4 ++-
> > > >  drivers/usb/chipidea/host.c        | 17 ++++++----
> > > >  drivers/usb/chipidea/otg_fsm.c     |  6 ++--
> > > >  drivers/usb/chipidea/udc.c         |  4 +--
> > > >  include/linux/usb/chipidea.h       |  4 ++-
> > > >  9 files changed, 86 insertions(+), 28 deletions(-)
> > > > 
> > > > diff --git a/drivers/usb/chipidea/ci.h b/drivers/usb/chipidea/ci.h
> > > > index 9563cb56d564..139589c8ab90 100644
> > > > --- a/drivers/usb/chipidea/ci.h
> > > > +++ b/drivers/usb/chipidea/ci.h
> > > > @@ -201,7 +201,9 @@ struct ci_hdrc {
> > > >  
> > > >         struct ci_hdrc_platform_data    *platdata;
> > > >         int                             vbus_active;
> > > > -       struct usb_phy                  *transceiver;
> > > > +       struct phy                      *transceiver;
> > > > +       /* old usb_phy interface */
> > > > +       struct usb_phy                  *usb_transceiver;
> > > 
> > > while at that, do you mind calling all struct usb_phy pointers
> > > 'usb_phy' ?
> > 
> > Not at all.
> > With s/usb_transceiver/usb_phy/, what about 'transceiver'?
> 
> perhaps call it phy ? That way all drivers have similar naming scheme.
> Plus, I rather type 3 letters than 11 :-p

I'll update then :)


-- 
Antoine Ténart, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to