Hi,

On Mon, 30 Jun 2014 08:41:18 +0000
David Laight <david.lai...@aculab.com> wrote:

> From: Of Richard Leitner
> > Replaces all hardcoded ttyGS strings with the PREFIX macro.
> > Due to the fact the strings are spread over different source files the
> > PREFIX definition is moved to u_serial.h
> 
> Lots of changes like:
> > -           DBG(cdev, "acm ttyGS%d completion, err %d\n",
> > -                           acm->port_num, req->status);
> > +           DBG(cdev, "acm %s%d completion, err %d\n",
> > +                           PREFIX, acm->port_num, req->status);
> 
> I'm not sure this improves the code.

Maybe you're right, the readability of the code wouldn't be better afterwards,
but as I already mentioned IMHO if there is such a macro it should be used 
everywhere or nowhere...

> Do you see a need to ever change PREFIX?

To be honest: I don't know who would ever need this (me probably not).

So the other idea is to carve it out completely?

> 
> Even if it is a reasonable change, the name PREFIX is hopeless.
> It would have to be something like ACM_TTYNAME_PREFIX.

good point.

> 
>       David

regards,
richard
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to