On Fri, Jun 20, 2014 at 11:21:13AM -0700, Davidlohr Bueso wrote: > From: Davidlohr Bueso <davidl...@hp.com> > > The arch_mutex_cpu_relax() function, introduced by 34b133f, is > hacky and ugly. It was added a few years ago to address the fact > that common cpu_relax() calls include yielding on s390, and thus > impact the optimistic spinning functionality of mutexes. Nowadays > we use this function well beyond mutexes: rwsem, qrwlock, mcs and > lockref. Since the macro that defines the call is in the mutex header, > any users must include mutex.h and the naming is misleading as well. > > This patch (i) renames the call to arch_cpu_relax (for lack of a better > name), and (ii) defines it in each arch's asm/processor.h local header, > just like for regular cpu_relax() functions. On all archs, except s390, > arch_cpu_relax is simply cpu_relax, and thus we can take it out of > mutex.h. While this can seem redundant or weird, I believe it is a > good choice as it allows us to move out arch specific logic from generic > locking primitives and enables future(?) archs to transparently define > it, similarly to System Z. > > Please note that these changes are only tested on x86-64.
While I like the general idea; does anyone have a better name for this? So in particular, the difference is that on s390: cpu_relax() - yields the vcpu arch_{,mutex_}cpu_relax() - will actually spin-wait -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/