Am 06.05.2014 11:35, schrieb Ingo Molnar: > > * Richard Weinberger <rich...@nod.at> wrote: > >>>> I like the idea but not the name. >>>> What about DIE() and DIE_ON()? >>> >>> CRASH_ON() might be a suggestive name as well, as from the user's >>> point of view we are crashing her system. >> >> I fear such users will think "Why should I crash the kernel?". ;-) > > That's exactly the impression that the naming should create in kernel > developers why try to add CRASH_ON() in the future: only do it as an > absolute last resort. > > WARN_ON() and other non-destructive ways to deal with error conditions > are almost always preferred.
Yeah, I was actually referring to the joke where one asks to remove all BUG() and BUG_ON() to make the kernel bug free. Thanks, //richard -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/