Hi, On 04/19, Pavel Machek wrote: > > > > Hmm. I seem to see a bug in this function, it can be fulled by use_mm, > > > but I am not sure this can explain the problem. I'll send a patch. > > > > Untested, please review. But it really looks "obviously wrong", and note > > that unuse_mm() doesn't do mm_update_next_owner(). (just in case, do not > > confuse it with unuse_mm() in mm/swapfile.c). > > Having two functions, one exported, one static with same name -- that > sounds quite evil, right?
Yes, agreed. > mmu_context.c: * unuse_mm > mmu_context.c:void unuse_mm(struct mm_struct *mm) > mmu_context.c:EXPORT_SYMBOL_GPL(unuse_mm); > swapfile.c:static int unuse_mm(struct mm_struct *mm, Yes, I was thinking about s/unuse_mm/unswap_mm/ change in swapfile.c, but then we should probaly rename other "unuse" functions there, and shmem_unuse/try_to_unuse are not static. Oleg. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/