On Sat, 19 Feb 2005 00:54:19 +0100, Adrian Bunk <[EMAIL PROTECTED]> wrote: > This patch contains the following possible cleanups: > - pci-acpi.c: make OSC_UUID static > - remove the following unused functions: > - pci-acpi.c: acpi_query_osc > - pci-acpi.c: pci_osc_support_set > - pci.c: pci_find_ext_capability > - rom.c: pci_map_rom_copy > - rom.c: pci_remove_rom > - remove the following unneeded EXPORT_SYMBOL's: > - pci-acpi.c: pci_osc_support_set > - rom.c: pci_map_rom_copy > - rom.c: pci_remove_rom
pci_map_rom_copy and pci_remove_rom are there to support boards that can't access their hardware and their ROM at the same time. These boards are known to exist but nobody has updated a driver yet to use the new routines. These should be left in place as the PCI spec explicitly allows the non-simultaneous access case. pci_remove_rom should probably be renamed to pci_remove_rom_copy. -- Jon Smirl [EMAIL PROTECTED] - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/