I wrote:
Please consider inlining alloc_page_array() and populate_page_array()
into relay_alloc_rchan_buf() as they're only used once. You'd get rid
of passing page_count as a pointer this way. If inlining is
unacceptable, please at least move the n_pages calculation to
relay_alloc_rchan_buf() to make the API more sane.

Andi Kleen writes:
Modern gcc (3.3-hammer with unit-at-a-time or 3.4) will do that anyways on its own.

I know that but I am commenting on readability. The pointer passing is due to silly interface (alloc_page_array() calculating number of pages on its own).


Pekka -
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

Reply via email to