On Fri, Feb 14, 2014 at 06:26:15PM -0600, Christoph Lameter wrote: > On Fri, 14 Feb 2014, David Rientjes wrote: > > > Yeah, you don't need it, but don't you think it makes the code more > > readable? Otherwise this is going to be just doing > > > > return (unsigned long)objp & ~SLAB_OBJ_PFMEMALLOC; > > > > and you gotta figure out the function type to understand it's returned as > > Isnt there something like PTR_ALIGN() for this case that would make it > more readable?
I can't find what you want. I agree with David's opinion and want to keep patch as is. Thanks. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/