On Mon, Dec 02, 2013 at 02:51:05PM -0800, Andrew Morton wrote: > On Mon, 02 Dec 2013 15:09:33 -0500 Naoya Horiguchi > <n-horigu...@ah.jp.nec.com> wrote: > > > > --- a/include/linux/rmap.h > > > +++ b/include/linux/rmap.h > > > @@ -235,11 +235,16 @@ struct anon_vma *page_lock_anon_vma_read(struct > > > page *page); > > > void page_unlock_anon_vma_read(struct anon_vma *anon_vma); > > > int page_mapped_in_vma(struct page *page, struct vm_area_struct *vma); > > > > > > +struct rmap_walk_control { > > > + int (*main)(struct page *, struct vm_area_struct *, > > > + unsigned long, void *); > > > > Maybe you can add parameters' names to make this prototype more readable. > > > > Yes, I find it quite maddening when the names are left out. They're really > very useful for understanding what's going on.
Okay. Will do. > > The name "main" seems odd as well. What does "main" mean? "rmap_one" > was better, but "rmap_one_page" or "rmap_one_pte" or whatever would > be better. Okay. I will think better name. Thanks. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/