On Thu, Oct 03, 2013 at 12:03:25PM -0700, Sukadev Bhattiprolu wrote: > Michael Ellerman [mich...@ellerman.id.au] wrote: > | On Tue, Oct 01, 2013 at 05:15:06PM -0700, Sukadev Bhattiprolu wrote: > | > Implement is_instr_load_store() to detect whether a given instruction > | > is one of the fixed-point or floating-point load/store instructions. > | > This function will be used in a follow-on patch to save memory hierarchy > | > information of the load/store. > | > | Anyway, I think the following logic is all we need for opcode 31: > | > | bool is_load_store(int ext_opcode) > > how about I call this is_load_store_2_06() and add a comment. Horrible > but minimizes chance of misuse.
Actually it's is_opcode_31_load_store_2_06() - which is even more horrible :) But you can probably fold it in to the main routine and then call that is_load_store_2_06(). Or whatever seems best, but yeah I think we should make it very clear that it's only for 2.06. cheers -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/