On Fri, 29 Jun 2001 07:10:51 -0700, 
"Adam J. Richter" <[EMAIL PROTECTED]> wrote:
>       The Config.in files in linux-2.4.6-pre6 have at least 28 cases
>where a dep_bool or dep_tristate of the following form:
>       dep_bool CONFIG_SOMETHING $CONFIG_ARCH_somearch
>       I will put together patch to convert this to ugly but correct
>"if then; ... ; fi" statements later today if nobody has any better
>suggestions.

Create arch/Config.in which contains

  define_bool CONFIG_ARCH_i386 n
  define_bool CONFIG_ARCH_ia64 n
  define_bool CONFIG_ARCH_sparc n

etc., then change each of the arch/xxx/Config.in files to
source arch/Config.in as their first line first.  Still ugly but the
mainline configs will be much more readable.  It also guarantees that
any future tests on $CONFIG_ARCH_somearch will work, even if the code
does not use if statements.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to