On Wed, Sep 11, 2013 at 06:26:25PM +0100, Al Viro wrote:
> On Wed, Sep 11, 2013 at 12:33:35PM -0400, Waiman Long wrote:
> 
> > >Folks, any suggestions on better names?  The semantics we are getting is
> > 
> > I will welcome any better name suggestion and will incorporate that
> > in the patch.
> 
> FWIW, the suggestions I've seen so far had been
> 
> seq_exreadlock() [ex for exclusive]
> seq_exclreadlock() [ditto, and IMO fails the "easily read over the phone"
> test - /sekv-excre...ARRGH/]
> seq_prot_readlock() [prot for protected, as in DLM protected read]

Though the DLM protected read doesn't self-conflict either so that's a
poor analogy, my bad.

(Do the users really require that the read be exclusive?)

--b.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to