> (Within the codebase, the filename and module name would still need the
> prefix: we use this for auto-module loading, function name/error message
> scoping etc.)

>> 3) writeboost or wboost
>> Concentrating on the characteristic b)
>> but doesn't mention cache.
> 
> I quite like that option.

OK,
I would like to rename from dm-lc to dm-writeboost.
Do you agree?

Akira

On 8/30/13 9:50 PM, Alasdair G Kergon wrote:
> On Fri, Aug 30, 2013 at 09:33:29PM +0900, Akira Hayakawa wrote:
>> I have three candidates on my mind.
>> I am thinking of removing the dm- prefix as bcache and enhanceio do.
>  
> Yes, that's fine for the general way of referring to this.
> (Within the codebase, the filename and module name would still need the
> prefix: we use this for auto-module loading, function name/error message
> scoping etc.)
> 
>>    a) It writes in-coming writes in log-structured manner.
>>    b) It is extremely fast in write.
>>    c) It is caching software.
> 
> Another candidate: 'lcache' - contrast with 'bcache
>  
>> 3) writeboost or wboost
>> Concentrating on the characteristic b)
>> but doesn't mention cache.
> 
> I quite like that option.
> 
> Alasdair
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to