On 08/13, Rafael J. Wysocki wrote: > On Tuesday, August 13, 2013 01:01:46 PM Tejun Heo wrote: > > Hello, > > > > On Tue, Aug 13, 2013 at 09:46:26AM -0700, Stephen Boyd wrote: > > > >> + if (PM_QOS_DEFAULT_VALUE != req->node.prio) > > > >> + pm_qos_update_target( > > > >> + > > > >> pm_qos_array[req->pm_qos_class]->constraints, > > > >> + &req->node, PM_QOS_UPDATE_REQ, > > > >> + PM_QOS_DEFAULT_VALUE); > > > > Maybe it'd be cleaner to add a param or internal variant of > > > > pm_qos_update_request()? > > > > > > Maybe, but I was trying to make a minimal fix here. > > > > Hmmm.... it just looks like things can easily get out of sync with the > > complex function call. > > Yes, that's just duplicated code. > > > I don't think it'll be too invasive if you introduce an internal variant > > which doesn't do the canceling. Rafael, what do you think? > > I'd move the part of pm_qos_update_request() below the > cancel_delayed_work_sync() to a separate static function that'd be > called from two places. >
Ok I will throw this all into one patch and resend. -- Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, hosted by The Linux Foundation -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/