On Tuesday, August 06, 2013 08:08:20 AM Nishanth Menon wrote: > change in subject to reflect new discussion. > > On 05:53-20130806, Randy Dunlap wrote: > > On 08/03/2013 02:25 AM, Viresh Kumar wrote: > > >Export opp_add() so that modules can use it. > > > > > >Signed-off-by: Viresh Kumar <viresh.ku...@linaro.org> > > >--- > > > drivers/base/power/opp.c | 1 + > > > 1 file changed, 1 insertion(+) > > > > > >diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c > > >index c8ec186..ef89897 100644 > > >--- a/drivers/base/power/opp.c > > >+++ b/drivers/base/power/opp.c > > >@@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, > > >unsigned long u_volt) > > > srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp); > > > return 0; > > > } > > >+EXPORT_SYMBOL_GPL(opp_add); > > > > Could it be renamed to pm_opp_add() or power_opp_add() ? > > The name is a bit too unspecific IMO. > Though this has nothing specific with this patch, an interesting point. > > git grep -w opp . showed drivers/tty/n_tty.c, > drivers/sbus/char/openprom.c and arch/powerpc/kvm/mpic.c using > variables named opp to mean what ever they had in context. rest(around > 40 odd files) seem to use opp as in Documentation/power/opp.txt.. > > We could go with a pm_ prefix or even dev_pm_opp_ prefix to be more > specific, though I prefer just pm_. If Rafael and others are ok, I can > post a series out.
Yup, that would be useful. I'm for dev_pm_opp_ if that matters. Thanks, Rafael -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/