On Thu, 2013-06-27 at 14:51 -0700, Stephen Hemminger wrote: > > > > +static inline int inet_pton(const char *str, union inet_addr *addr) > > +{ > > > > A couple of comments: > 1. No reason for this to be inline
Okay, I will move them into net/core/utils.c. > 2. If function has same name as userspace it must have same arguments > and return value. Either: > a. rename it to kinet_pton or some other name > b. make it work the same. > Makes sense too me, I will try your option b) first, if it is over-kill I will fall back to option a). Thanks! -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/