On 29/06/13 04:44, H Hartley Sweeten wrote:

> This inline helper function is only used to determine the bus width
> of the current transfer (8 or 16 bit). Add a bool flag to the private
> structure and set it appropriately for each transfer.
> 
> Signed-off-by: H Hartley Sweeten <hswee...@visionengravers.com>
> Cc: Ryan Mallon <rmal...@gmail.com>
> Cc: Mika Westerberg <mika.westerb...@iki.fi>
> Cc: Mark Brown <broo...@kernel.org>
> Cc: Grant Likely <grant.lik...@linaro.org>
> ---
>  drivers/spi/spi-ep93xx.c | 16 +++++-----------
>  1 file changed, 5 insertions(+), 11 deletions(-)
> 
> diff --git a/drivers/spi/spi-ep93xx.c b/drivers/spi/spi-ep93xx.c
> index bcfd35a..4fab3bb 100644
> --- a/drivers/spi/spi-ep93xx.c
> +++ b/drivers/spi/spi-ep93xx.c
> @@ -116,6 +116,7 @@ struct ep93xx_spi {
>       unsigned long                   min_rate;
>       unsigned long                   max_rate;
>       bool                            running;
> +     bool                            word_xfer;


I think this is a slightly confusing name. Maybe something like
is_16bit_xfer would be better?

>       struct workqueue_struct         *wq;
>       struct work_struct              msg_work;
>       struct completion               wait;
> @@ -407,17 +408,9 @@ static void ep93xx_spi_chip_setup(const struct 
> ep93xx_spi *espi,
>       writew(cr0, espi->regs_base + SSPCR0);
>  }
>  
> -static inline int bits_per_word(const struct ep93xx_spi *espi)
> -{
> -     struct spi_message *msg = espi->current_msg;
> -     struct spi_transfer *t = msg->state;
> -
> -     return t->bits_per_word;
> -}
> -
>  static void ep93xx_do_write(struct ep93xx_spi *espi, struct spi_transfer *t)
>  {
> -     if (bits_per_word(espi) > 8) {
> +     if (espi->word_xfer) {
>               u16 tx_val = 0;
>  
>               if (t->tx_buf)
> @@ -436,7 +429,7 @@ static void ep93xx_do_write(struct ep93xx_spi *espi, 
> struct spi_transfer *t)
>  
>  static void ep93xx_do_read(struct ep93xx_spi *espi, struct spi_transfer *t)
>  {
> -     if (bits_per_word(espi) > 8) {
> +     if (espi->word_xfer) {
>               u16 rx_val;
>  
>               rx_val = readw(espi->regs_base + SSPDR);
> @@ -522,7 +515,7 @@ ep93xx_spi_dma_prepare(struct ep93xx_spi *espi, enum 
> dma_transfer_direction dir)
>       size_t len = t->len;
>       int i, ret, nents;
>  
> -     if (bits_per_word(espi) > 8)
> +     if (espi->word_xfer)
>               buswidth = DMA_SLAVE_BUSWIDTH_2_BYTES;
>       else
>               buswidth = DMA_SLAVE_BUSWIDTH_1_BYTE;
> @@ -699,6 +692,7 @@ static void ep93xx_spi_process_transfer(struct ep93xx_spi 
> *espi,
>  
>       ep93xx_spi_chip_setup(espi, chip);
>  
> +     espi->word_xfer = (t->bits_per_word > 8) ? true : false;


        espi->word_xfer = (t->bits_per_word > 8);

This patch is fine, but not sure it is entirely worth it. The
information is already stored in t->bits_per_word and the cost
of retrieving it is pretty minimal.

~Ryan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to