KOSAKI Motohiro <kosaki.motoh...@gmail.com> writes: >> Instead of reverting and renaming --discard, what about making it accept an >> optional argument, so we could use --discard (to enable all thing and keep >> backward compatibility); --discard=cluster & --discard=batch (or whatever we >> think it should be named). I'll try to sort this approach out if you folks >> think >> it's worthwhile. > > Optional argument looks nice, at least to me. > > But hmm.. > > "cluster" and "batch" describes current kernel implementation, not user > visible effect. > Usually I suggest to pick up a word from man pages because it describe user > visible action. > e.g. --discard=freed-pages or --discard=io or --discard=swapon or > --discard=once, etc.. > > But this is not strong opinion. You can ignore it. I don't think I have good > English sense. :-)
I like discard=swapon. For the fine-grained discards, I don't have a strong opinion, but I guess I'd lean towards freed-pages. Cheers, Jeff -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/