On Fri, Apr 19, 2013 at 7:36 PM, Daniel Mack <zon...@gmail.com> wrote: > Hi Michal, > > On 19.04.2013 15:38, Michal Bachraty wrote: >> Add devicetree support for this dummy audio soc driver. > > I think Mark wants to see only "ASoC:" in the patch subjects now. > >> >> Signed-off-by: Michal Bachraty <michal.bachr...@streamunlimited.com> >> --- >> sound/soc/codecs/spdif_transciever.c | 10 ++++++++++ >> 1 file changed, 10 insertions(+) >> >> diff --git a/sound/soc/codecs/spdif_transciever.c >> b/sound/soc/codecs/spdif_transciever.c >> index 112a49d..4c8c295 100644 >> --- a/sound/soc/codecs/spdif_transciever.c >> +++ b/sound/soc/codecs/spdif_transciever.c >> @@ -20,6 +20,7 @@ >> #include <sound/soc.h> >> #include <sound/pcm.h> >> #include <sound/initval.h> >> +#include <linux/of.h> >> >> #define DRV_NAME "spdif-dit" >> >> @@ -52,12 +53,21 @@ static int spdif_dit_remove(struct platform_device *pdev) >> return 0; >> } >> >> +#ifdef CONFIG_OF >> +static const struct of_device_id spdif_dit_dt_ids[] = { >> + { .compatible = DRV_NAME, }, > > I think this needs a "linux," prefix. Just put the whole string here.
Michal, I suggest to also rename spdif_transceiver to spdif_transmitter, as "transceiver" usually do both "transmit" and "receive". I don't know who made up the current name, but the driver is definitely a transmitter. Sebastian -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/