On 13-04-18 07:14 AM, Peter Zijlstra wrote: > On Mon, 2013-04-15 at 11:33 +0200, Ingo Molnar wrote: >> * Paul Gortmaker <paul.gortma...@windriver.com> wrote: >> >>> Recent activity has had a focus on moving functionally related blocks of >>> stuff >>> out of sched/core.c into stand-alone files. The code relating to load >>> average >>> calculations has grown significantly enough recently to warrant placing it >>> in a >>> separate file. >>> >>> Here we do that, and in doing so, we shed ~20k of code from sched/core.c >>> (~10%). >>> >>> A couple small static functions in the core sched.h header were also >>> localized >>> to their singular user in sched/fair.c at the same time, with the goal to >>> also >>> reduce the amount of "broadcast" content in that sched.h file. >> >> Nice! >> >> Peter, is this (and the naming of the new file) fine with you too? > > Yes and no.. that is I do like the change, but I don't like the > filename. We have _waaaay_ too many different things we call load_avg. > > That said, I'm having a somewhat hard time coming up with a coherent > alternative :/
Several of the relocated functions start their name with "calc_load..." Does "calc_load.c" sound any better? -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/