On Tue, Feb 12, 2013 at 11:09:00PM +0000, Arnd Bergmann wrote: > On Tuesday 12 February 2013, gre...@linuxfoundation.org wrote: > > > > > > > Please let's find something that makes both hw and Linux happy > > > I still believe it makes sense to use mei_device for what we add to the > > > MEI > > > bus. I'd be fine with mei_bus_device as well, but that would somehow look > > > a bit awkward. Greg, Arnd, any preference ? > > > > "mei_device" works the best for me. Tomas, what you think of as a "MEI > > Device" really is a "MEI Controller", it bridges the difference between > > the PCI bus and your new MEI bus, so you will need to start thinking of > > these things a bit differently now that you have created your own little > > virtual bus. > > Yes, I agree. mei_bus_device would also work as the name for the controller, > but not for the devices attached to it IMO. Tomas, I propose to switch to mei_controller instead of mei_host and keep the mei_device name for the devices we attach to the MEI bus. Does that work for you ?
Cheers, Samuel. -- Intel Open Source Technology Centre http://oss.intel.com/ -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/